Trouble uploading CSV to Formidable Pro

Labels

This Discussion is public

Notifications

Hi!

I'm trying to use the Import/Export feature in Formidable Pro, however, I keep getting the following error:

  • That CSV was not uploaded. Are CSV files allowed on your site?

I've added the CSV filetype/extension/MIME to the supported file formats previously so I try to upload it to the Media Library directly and get a similar error:

“filename.csv” has failed to upload.
Sorry, this file type is not permitted for security reasons.

I read in the FP Help Desk that this can be related to the auto-increment conditon in the site's DB, from this link:

That CSV was not uploaded. Are CSV files allowed on your site?

However, it's not clear to me where/how to achieve this. Any clues??
Thanks!

Francisco

I have had this problem before and had to go into the database to fix but this has come up again after the last update to wordpress.  I'm not sure if this is correct but it seems to have blocked csv files by default due to security.

So test this by importing a csv file to your media library, if it says you can't then do the following.

Put the following line into your wp-config.php file, it will bypass this file blocking.

define('ALLOW_UNFILTERED_UPLOADS', true);

If you want to just allow a certain file type you will have to add some code to your functions.php, you should be able to google the warning you got when your imported into the library.

Thanks Smittyhead!

I can see now that this issue should go away with the next release:
https://core.trac.wordpress.org/ticket/39550

The solution for now would be to add the code you sent or use a plugin like this one to disable the MIME check:
https://wordpress.org/plugins/disable-real-mime-check/

At least until WP 4.7.2 is released...

Regards!

Hello, I am struggling with this matter for days and no one can say something reasonable to make it to work.

My WP version is the latest one 4.9, my server  is  Centos 7. PHP 5.6 MariaDB 10, self managed.

My check list, I did this all:

define('ALLOW_UNFILTERED_UPLOADS', true); in my wp-config = OK
switch themes to (twentysixteen and genesis child) = ok
disable all the plugins except formidable pro of course = OK
Uploaded the same CSV t0 my WP media uploads = OK
Uploaded the same CSV file to a non-WP application = OK
My Server Mime types supports .CSV = OK
I used "Manage Mime Types" to be sure = OK
Consulted my Apache log several times and it says nothing about Formidable occurencies = OK
My CSV file is UTF_8 encoded = OK
My CSV structure is as Windows-Dos, first line column headers separate by commas and separated as  "data", exactly as displayed on hundreds of formidable tutorials that I have read. = OK
My CSV has 138 rows and 4 columns only (very small), I reduced to 10 rows as attached, didn't work as well = OK
I used Note ++ to handle UFT-8 files = OK

Please see attached CSV, the message is always the same, (That CSV was not uploaded. Are CSV files allowed on your site?)

Is there some extra magic I can do to make it to work?

Thanks,

 


Attachment:
COPIED-csv-import_formidable_entries-w-dos-uft8.csv

Did this ever get resolved?

 

BUMP...

Reply to this Discussion